RE:[sap-basis] SAP PI 7.1 - Communication Channel error
Posted by
Admin at
|
Share this post:
|
0 Comments
| | Posted by D. Caddick (SAP NetWeaver/BASIS Consultant) on Feb 10 at 5:47 PM | |
Hi D Q,
Thank you for letting the group know that the problem is solved.
Regards
---------------Original Message---------------
From: dbasis77
Sent: Monday, February 08, 2010 11:20 AM
Subject: SAP PI 7.1 - Communication Channel error
> Hi All,<br/>We have configured a JDBC receiver channel in PI 7.1 to import a database table structure in IR by using the new dbtab feature in external definition.<br/>The DB I?m trying to connect to is a MS SQL Server 2000 one. The jdbc driver we have deployed is the sqljdbc.jar included on Microsoft SQL Server JDBC Driver 2.0. The value for the JDBC Driver and Connection parameters are as follows:<br/>? com.microsoft.sqlserver.jdbc.SQLServerDriver<br/>? jdbc:sqlserver://<db_Server>:port;databaseName=<db_ name><br/>While trying the import of a table in PI 7.1 in the external definition of IR, I faced JDBC connectivity: A - Error occurred while attempting to connect to database. The error details are: <br/>B - Exception during processing the payload. Error when calling an adapter by using the communication channel cc_reciever_database (Party: , Service: bs_receiver_interfase_caja_diaria, Object ID: e49d4d1013f237649ca75c1f651c46bb) XI AF API call failed. Module exception: (No information available). Cause Exception: 'JDBC Adapter configuration not initialized: null'.<br/>In CC monitoring (of the RWB), the error message says:<br/>C -Error when attempting to get processing resources: com.sap.aii.af.lib.util.concurrent.ResourcePoolExce ption: Unable to create new pooled resource: DriverManagerException: Cannot establish connection to URL 'jdbc:sqlserver:// <db_Server>:port;databaseName=<db_name>?: com.microsoft.sqlserver.jdbc.SQLServerException: Logon failure user 'xxxxx'.<br/>It worth to mention that in RWB also, the following info is displayed in CC monitoring (Cluster tab) for the affected CC:<br/>Status: Red light<br/>ShortLog: Channel has internal error<br/>Control data:?????<br/>In the Administration Information tab, the message is D -Channel has internal error.<br/>As a validation, and taking under consideration that the deployment process has finished successfully, we were able to check the existence of the sqljdbc.jar file in: \usr\sap\<SID>\DVEBMGSXX\j2ee\cluster\bin\ext\com. sap.aii.adapter.lib\lib.<br/>In NWA, the XPI Adapter: JDBC services is started. Also, the client port (1433) was checked and through the ODBC we were able to established the connection to the DB. However, the user we are using is not an SQL one (I mean is not the sa user for example). The user we were given only has w/r access to an specific table. Is there any special requisite for the user being used in the communication channel. I?m mentioning that since the error described in last part of the error C detailed above.<br/>Please let me know if there is any other check I could to do in order to determine the issue is related to an incorrect sql driver, deployment of that driver or wrong user.<br/>Thanks for your help.<br/>Regards
__.____._ Thank you for letting the group know that the problem is solved.
Regards
---------------Original Message---------------
From: dbasis77
Sent: Monday, February 08, 2010 11:20 AM
Subject: SAP PI 7.1 - Communication Channel error
> Hi All,<br/>We have configured a JDBC receiver channel in PI 7.1 to import a database table structure in IR by using the new dbtab feature in external definition.<br/>The DB I?m trying to connect to is a MS SQL Server 2000 one. The jdbc driver we have deployed is the sqljdbc.jar included on Microsoft SQL Server JDBC Driver 2.0. The value for the JDBC Driver and Connection parameters are as follows:<br/>? com.microsoft.sqlserver.jdbc.SQLServerDriver<br/>? jdbc:sqlserver://<db_Server>:port;databaseName=<db_ name><br/>While trying the import of a table in PI 7.1 in the external definition of IR, I faced JDBC connectivity: A - Error occurred while attempting to connect to database. The error details are: <br/>B - Exception during processing the payload. Error when calling an adapter by using the communication channel cc_reciever_database (Party: , Service: bs_receiver_interfase_caja_diaria, Object ID: e49d4d1013f237649ca75c1f651c46bb) XI AF API call failed. Module exception: (No information available). Cause Exception: 'JDBC Adapter configuration not initialized: null'.<br/>In CC monitoring (of the RWB), the error message says:<br/>C -Error when attempting to get processing resources: com.sap.aii.af.lib.util.concurrent.ResourcePoolExce ption: Unable to create new pooled resource: DriverManagerException: Cannot establish connection to URL 'jdbc:sqlserver:// <db_Server>:port;databaseName=<db_name>?: com.microsoft.sqlserver.jdbc.SQLServerException: Logon failure user 'xxxxx'.<br/>It worth to mention that in RWB also, the following info is displayed in CC monitoring (Cluster tab) for the affected CC:<br/>Status: Red light<br/>ShortLog: Channel has internal error<br/>Control data:?????<br/>In the Administration Information tab, the message is D -Channel has internal error.<br/>As a validation, and taking under consideration that the deployment process has finished successfully, we were able to check the existence of the sqljdbc.jar file in: \usr\sap\<SID>\DVEBMGSXX\j2ee\cluster\bin\ext\com. sap.aii.adapter.lib\lib.<br/>In NWA, the XPI Adapter: JDBC services is started. Also, the client port (1433) was checked and through the ODBC we were able to established the connection to the DB. However, the user we are using is not an SQL one (I mean is not the sa user for example). The user we were given only has w/r access to an specific table. Is there any special requisite for the user being used in the communication channel. I?m mentioning that since the error described in last part of the error C detailed above.<br/>Please let me know if there is any other check I could to do in order to determine the issue is related to an incorrect sql driver, deployment of that driver or wrong user.<br/>Thanks for your help.<br/>Regards
Copyright © 2010 Toolbox.com and message author.
Toolbox.com 4343 N. Scottsdale Road Suite 280, Scottsdale, AZ 85251
Toolbox.com 4343 N. Scottsdale Road Suite 280, Scottsdale, AZ 85251
SAP Basis Top Contributor
Contributed the most posts in a group for 3 consecutive months to earn a Gold Achievement
Related Content
In the Spotlight
White Papers
In the Spotlight
Earn Recognition for Your Contributions at Toolbox for IT. Gain Points for Community Achievements
View this thread online
Manage group e-mails
Create an FAQ on this topic
Tell us what you think
Unsubscribe from discussion
Manage group e-mails
Create an FAQ on this topic
Tell us what you think
Unsubscribe from discussion